SAP Knowledge Base Article - Public

2290943 - After Migration of Appointment Activities the Status of the Visits Changes From Completed to Open

Symptom

After modifying Appointment Activities through Migration the status of the Visits changes from Completed to Open

Reproducing the Issue

1. Go to Business Configuration work center
2. Select Implementation Projects view or Overview.
3. Search and Open the migration activity Migration of Appointment Activities
4. Execute Migration for the respective Migration File

Cause

This is because you are using migration mode Modify Already Existing Records and you have kept the Status field as blank. There is a rule applied for the Status field that as long as it contains new value, then it is set to Open.

Resolution

Fill the Status field as Completed and then migrate there will be no change in Status of Visits.

You can also use Mass Data Maintenance work center for this where you can download the Appointment Activities  and the Status field will be prefilled while Importing.

This is standard system behaviour.

Keywords

KBA , LOD-CRM-ACT , Activities , How To

Product

SAP Hybris Cloud for Customer add-ins 1702 ; SAP Hybris Cloud for Customer add-ins 1705 ; SAP Hybris Cloud for Customer add-ins 1708