Symptom
In the Business Configuration overview, when you try to edit an activity, system throws the below message:
Settings cannot be changed.
Activity is read only. To edit this activity, add it to your project
Environment
- SAP Cloud for Customer
- SAP Business ByDesign
Reproducing the Issue
- Go to Business Configuration work center.
- Access the Overview view.
- Search for the relevant activity.
- Click the Edit or Change Immediately button.
- You see the message.
Cause
The message is displayed due to one of the below reasons:
- You do not have an open project (with status Started) on your tenant.
- The activity in question is not added to any project.
Resolution
If you do not have an open project on your tenant, please create a change project and add the fine-tuning activity to the change project in order to edit the activity.
To add the activity to an existing change project, you need to follow the below steps:
- Go to the Business Configuration work center.
- Access the Implementation Projects work center view.
- Select the available project and click Open Activity List.
- Show All Activities.
- Select the Fine-Tune tab.
- Search for the relevant activity.
- Click the Add to Project button.
Another possibility for this scenario is when there is no button to 'Edit' or 'Add Row' in the activity. In such cases, you will also receive a warning message as well. This is the expected system behavior.
Keywords
Activity is read only, read only, settings cannot be changed, business configuration, open activity, edit activity, overview, Change Immediately , KBA , charts of accounts , activity is read-only , settings cannot be changed , activity is read only , AP-RC-BCT , Business Config. Tools (SAP Business ByDesign , How To