Symptom
When importing contents, the background job fails due to a timeout. How to adjust these settings?
Caused by: org.apache.commons.vfs2.FileSystemException: Could not close the output stream for file
Job timeout on: reason: JOB_TIMEOUT: Job was running for longer than {x} seconds
Environment
SAP SuccessFactors Learning
Resolution
Please follow the below steps in the Learning admin side:
- At Learning Administration > System Administration > Configuration > System Configuration > open the file CONTENT IMPORT in edit mode >
- To increase the size of import file, please update the below setting:
- maximumFileSizeKB (which stands for the maximum size of a single attachment in KB)
- To increase the timeout period for content import, please update the below setting:
- handlerTimeout (please note the value to be added needs to be in milliseconds. Note this timeout should be less than your HTTP server's timeout).
Note: there is no restriction on the number of content files that can be uploaded simultaneously. However, importing multiple files with a large size may result in the import job timing out.
See Also
- KBA 2256194 - Import Content Tool - Failed
- KBA 2294748 - How to increase the size of the content import and timeout settings
- KBA 2416189 - How to setup and use iContent with SuccessFactors Learning
- SAP Help Portal | Edit CONTENT IMPORT
- SAP Help Portal | Configuring Attachment Logic and Limits in SAP SuccessFactors Learning
Keywords
content, import, handlerTimeout, maximumFileSizeKB, timeout, time, out, increase, size, limit, change, modify, Could not close the output stream for file, Job was running for longer than {x} seconds , KBA , LOD-SF-LMS-CNT , Content , How To
SAP Knowledge Base Article - Public