Symptom
Certain employees or managers that have the permission (set in RBP) to use "document generation" tools (tools like "Manage Document Template" and "Manage Document Template Mapping") are unable to see or access these tools within admin center.
Environment
SAP SuccessFactors Employee Central
Cause
-
The cause could be that some tools rely on the base Metadata framework permissions to be set as well for the specific employees.
- Also note that tools like "documentation generation mapping" are configuration/administration related tools, so some basic other tools are needed as well to be able to access this tool.
Resolution
- Make sure that the user has related permissions under "Manage Document Generation" table in RBP. The permissions available here are: Manage Document Template, Manage Document Template Mapping, Generate All Documents as Admin, Mass generate all documents as an admin.
-
For the Document generation tools to come up, make sure you set the permissions under the "Metadata Framework" section of the specific role you have defined for your employees:
Manage Data
Configure Business Rules
Access to non-secured objects
Keywords
Permission, RBP, Metadata, Document Generation, admin tools not visible , KBA , LOD-SF-EC-DOC , Document Generation , Problem