Symptom
Despite having role based permission setup correct, with access to the right modules and target population, you might encounter the error message [Role based security prevents the viewing of this component].
Cause
Checking the user maintenance, you can search for an affected user (user ID)
Select the below marked fields from "Choose Columns", by moving them with the arrows in the middle from the "Available Columns" to the "Selected Columns":
Once you click "OK", it will refresh the view, showing the additional columns content for the user:
The SF Company ID and Internal ID is used by the Analytics application to retrieve the data for the user for any report looked at. As the Online Report Designer does not contain Live Data, but retrieves it when needed, the user would not be able to see any data for any Live Data Report or Query.
Resolution
Solution 1:
It is recommended to let Analytics auto create the users to prevent this from happening. Any time a new user navigates to the Online Report Designer, it will be created with all needed details in a standard reporting role (designates tool level access in the Online Report Designer). Deleting the user and have him or here navigate to the Online Report Designer would fix this.
This will leave the new user in a predefined standard role in the Online Report Designer, so it makes sense to check and amend the role if needed once the user appears again in the user maintenance.
Solution 2:
For a larger number of users one might want to utilise the Bulk User Upload functionality: Bellow is available under "Admin" inside of the Online Report Designer
This function is available for User with the Implementation Partner Role in the Online Report Designer backend: Admin -> User Mainteance -> select user -> Edit user
and assign role from drop down.
This would require to add the required information to each user after downloading a list of affected users from the user maintenance. Bellow an empty example list of the required fields. Please note that the field "User Active" needs to be maintenained, as this solution utilises the overwride functionality in the next step:
Next step is to navigate to the Bulk User Load in the first screen when navigating in the Online Report Designer to "Admin":
The arrows bellow show the important areas: Overwrite will update the fields, so the changes you applied to the excel file will update the user records. The second arrow might not be applicable depending on the setup or version of your instance. The proposed "Add to returned spreadsheet" selection is recommended as no user should need a password as this is handled via Single Sign On.
Click upload users (no visible in the screenshot above) and wait for it to process the changes.
It is recommended to log out the affected users and have the login fresh to test. If you still see issues, open an case with support explaining that you changed the user maintenance via Bulk upload and the server cache for the company might need to be cleared in analytics.
Keywords
Online Report Designer, ORD, Advanced Reporting, RBP, Role based permission, [Role based security prevents the viewing of this component], empty report, empty query , KBA , LOD-SF-ANA-ORD , Online Report Designer , Problem