Symptom
Some employees who were terminated and set to Inactive, are becoming Active again after a period of time.
Environment
SAP SuccessFactors Employee Central - Termination
Cause
- This issue can be caused by Basic User Imports, in which the users are being set back to active.
- This can also be caused by the API, which updates the status of the employee back to active.
Resolution
Before applying the solution, please check the following:
- Termination Event has a valid External Code
- Termination Event Reason has correct Employee Status (Terminated)
- Employee Status picklist has correct External Code set against Termination status.
- All event and employee status picklist entries are active and match those in the master picklist
- HRIS daily sync is completing with no errors
- Issue is temporarily resolved after running a HRIS Full Sync and employees become inactive again, however the issue would reoccur after some days and the employee becomes active once again
In order to fix the issue, do the following:
- Check in Admin Tools > Manage Scheduled Jobs, if the Employee Data Import (for Employee Central only) job is being run manually on the system. These jobs may be part of compensation data (e.g bonus cycle). This might put the inactive employees Active in the public profile area only. Run a basic import of the inactive employees so they no longer appear in the Org charts or search bar.
- Create a Change Audit report for the affected user and check whether the status is updated through API
See Also
2744431 - How to create a Change Audit Report and what reports are available? - FAQ
Keywords
Terminated Employees, Active, Basic User Import, still active, after termination, status, back to active, deactivate, contigent worker , KBA , LOD-SF-EC-TER , Termination Details , LOD-SF-EC-EDP , Import Employee Data (EC Core only) , LOD-SF-EC-HRS , HRIS Sync , Problem