Symptom
Users and managers do not receive the "System Pending Enrollment" notifications.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- User registers for an item that has approval process enabled > Managers are the approvers >
- User receives confirmation of approval request > Manager receives approval request >
- Once approved, pending enrollment notifications are not being sent.
Cause
The approval process notifications have been successfully delivered to both learning user and approver(s).
Resolution
The application is designed to suppress any pending enrollment notifications when approval notifications are delivered. As there is no longer a need for a pending enrollment notification to be delivered, the pending enrollment notifications are obsolete, and no longer in use, when it comes to the approval process flow. This behavior is by-design.
Please note that the template "SystemPendingEnrollmentNotification" is still used by the system at the scenario below:
- A user registers into a class with approval process and it's not approved yet >
- At the class > "Details" tab > Under "Email Confirmation for Admin-Initiated Actions" > Users are set as recipient (Email confirmation to the User > Yes) >
- At the class > "Actions" button > Resend Registration Email Notifications >
- User receives a "Pending Enrollment Notification".
Keywords
SystemPendingEnrollmentNotification, ApprovalProcessInitialRequest, notification, pending, email, self-register, approval, trigger, launched, not, received, sent, problem, how-to, class, contacts, instructor, supervisor, manager, kal, kac , KBA , LOD-SF-LMS-NOT , Notifications , Problem