Symptom
After adding a new Pay Component to the system via Admin Center the administrator finds the newly added Pay Component is not shown (displayed) in the Pay Component drop down list when editing the employee's Compensation record.
Reproducing the Issue
Add a new Pay Component to the system via Admin Center and attempt to use it when editing an employee's Compensation record by adding the newly added Pay Component through the Take Action button or Insert New Record. When doing so the adminstrator should find the new Pay Component is not shown in the Pay Component drop down list.
Cause
The new Pay Component is not displayed in the Pay Component drop down list because the RBP permission group associated with the adminstrator does not have either the "view" or "edit" rights checked for the new Pay Component in the pemission role.
Resolution
To resolve the problem you should edit each RBP permission role for which a user or group of users are allowed view and/or edit the new pay component by ensuring the the appropriate permission checkboxes checked.
Steps:
- Admin Center > Manager Permission Roles
- Find the appropriate permission role for the user/users and open it [Super Admin for example]
- Click the “Permission” button
- Click “Employee Data”
- Navigate by scrolling down to the “Pay Components” section and find the new pay component you previously created.
- Check off the “view” and/or “edit” check box options as appropriate for the role and “Save”
- Go to the employee record, open the Pay Component section and "edit" the record via "insert new record" or use "take action" to edit the compensation record to add the new pay component – you will now see the newly added pay component in the drop dow list.
See Also
2270326 - How to configure which Pay Components should be displayed in payComponentNonRecurring and payComponentRecurring portlets
Keywords
Pay Component , KBA , LOD-SF-EC-CMP-REC , Recurring Payments , Problem