SAP Knowledge Base Article - Public

2300111 - Error: "Unable to Fetch Connection Parameters", when attempting to connect to Salesforce in Lumira

Symptom

  • Error: "Unable to Fetch Connection Parameters"
  • When attempting to connect to Salesforce.com from Lumira, it fails.
  • In Lumira Desktop, when trying to use Salesforce JDBC driver, it generates the error: "Unable to fetch connection parameters"
     
    Lumira Error.png
          
      
  • When performing a trace in Lumira, the log files recorded the following entry:
         
    2016/02/03 19:25:57.362000|==|S| |14628|  47| |||||||||||||||[com.sap.hilo.desktop.v2.V2Main$StreamGobbler]SAPLumira.exe output:
    [0324/192557:INFO:CONSOLE(432)] "Uncaught TypeError: Cannot read property '0' of undefined", source: http://127.0.0.1:57195/fhsv2/sap/vi/desktop/datasource/freehandsql/supported/db/FreeHandSQLConnectionParametersController.controller.js (432)

Environment

  • SAP Lumira Desktop 1.x
  • Salesforce.com JDBC driver

Reproducing the Issue

  1. In Lumira Desktop, click "New Document"
  2. Select "Query with SQL" option
  3. Select "Salesforce.com - JDBC Drivers" from the list, then click: "Next"
  4. Error message pops up

Cause

  • Corruption of Lumira Desktop related files caused this issue.

Resolution

  • Note: The following steps will reset Lumira Desktop settings including license key, recent data sources, logs, etc. Existing Lumira documents are not affected.
    1. Close Lumira Desktop
        
    2. Take a backup of the content in these folders: on the machine where Lumira Desktop is installed
      • %TEMP%\sapvi\
      • %HOMEPATH%\.sapvi\
      • C:\Users\Public\sapvi\
          
    3. Delete everything from the folders listed above
       
    4. Restart Lumira Desktop.
          
      You will be able to conect to Salesforce.com using the JDBC driver.

Keywords

lum, dsk, sf, crm, jdbc, driver, connection, connectivity, error, issue, problem, cannot, can't, can, not, use, open, start, continue, proceed, connect , KBA , BI-LUM-DIS , Lumira Desktop/Discovery , Problem

Product

SAP Lumira, desktop edition 1.0