Symptom
- Whenever a new record is insterted/upserted/updated via API(SFAPI/Odata), one email notification gets triggerred to an email id in below format-
- This email notification was never specifically subscribed by the customer.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
Successfactors BizX system
Reproducing the Issue
Update any user in Successfactors instance via API call.
Cause
- This notification is sent to the email id specified for the username used to perform this update/upsert operation.
- And in order to identify which user, go to the API Audit Logs(choose SFAPI/Odata depending upon which API protocol was used to perform the operation) and search for the corresponding 'update/upsert' operation.
- Once done, you will see a screen like below(Odata API Audit Log screenshot for example)-
- Now on this screen, you need to view the value for the field 'Login ID' for the corresponding operation.
- And you can then check for the email Id specified in the system for this user by viewing this user's profile.
- Now this is a designed behavior and cannot be changed.
Resolution
Now, in case you don't want to receive these email notifications you can follow below recommendations-
- Create a user specifically for API operations.
- Now you can either leave the email id field blank or provide a dummy email id(in case it is marked as mandatory for your instance) so that you do not receive these email notifications.
Keywords
OData Login ID, OData email notification , KBA , LOD-SF-INT-ODATA , OData API Framework , LOD-SF-INT , Integrations , Problem
Product
SAP SuccessFactors HCM Suite all versions