SAP Knowledge Base Article - Public

2304090 - Successfully Migrated Warranties are Missing in the Respective Work Center

Symptom

You are in the process of migrating Warranties and the migration successfull but those Warranties are missing in Warranties view of Service Entitlements work center.

Reproducing the Issue

  1. Migrate the Warranties using Migration of Warranties fintuning activity in Business Configuration
  2. Go to Service Entitlements work center
  3. Go to Warranties view
  4. Show All Warranties

Migrated Warranties are missing

Cause

The cause for the issue could be as follows,

You are trying to migrate Warranties with Product Category assigned to it. For the product category, if the product assignment allowed indicator is set to false. Then the Warranties wont be migrated.

This can be verified in that the Product Assignment Allowed indicator is not checked in the Product Categories view (Product Data workcenter) for the Product Category

Resolution

Notes for the User:

1. If you really intend to not allow product assignment to product category, then uncheck this option from the product category maintenance *before you assign this category to any products*
2. If you want to allow product assignment to product category, then first ensure that these categories allow product assignments.

In General,  Warranty is also treated as a product, and therefore in this context, the same rule applies. In order to assign a product category to the warranty, the product assignment allowed indicator needs to be set to true for that product category.

Keywords

KBA , SRD-CRM-SEE , Service Entitlements , How To

Product

SAP BUSINESS BYDESIGN 1611 ; SAP BUSINESS BYDESIGN 1705 ; SAP Business ByDesign 1608 ; SAP Business ByDesign 1702