Symptom
Fields are set to null on Payment Information or the portlet is continuously loading.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HCM Suite
- SAP SuccessFactors Employee Central
Reproducing the Issue
- Edit Payment Information field like:
- Pay Type
- Payment Method
- Bank Country
- Bank
- Routing Number
- Account Number
- Currency
- Amount
- See that the field is set to null/empty or portlet keeps on loading
Cause
This can be caused by UI Rules which are attempting to set values for the fields.
UI Rules configured on Manage Configuration UI should not be used to modify or set field data, only to change UI parameters like visibility
Business Rules configured on Configure Business Rules should be used to change or set field data on Payment Information.
Resolution
Remove or replace any UI Rules which are attempting to set field values.
- On Manage Configuration UI
- Select the ScreenID used for Payment Information Details on Configure People Profile
- on the Payment Information Header, select Manage UI Rules
- Edit the Rule and verify that it does not Set field values (any rule like this should be converted into a business rule)
Example of Wrong UI Rule (do not copy):
See Also
Keywords
Payment Information, loading, null, edit, blank, empty, fields, PaymentInfoUIRulesOnlyRequiredAndVisibility, UI Rule, Manage Configuration UI, payment info, set, view , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , Problem
SAP Knowledge Base Article - Public