SAP Knowledge Base Article - Public

2307036 - Page Layouts in Responsive UI

Symptom

You have done Page Layout changes and assigned to a Business role in HTML5. But changes are not reflected in Responsive UI

Reproducing the Issue

  1. In Adapt -> Edit Page Layout XYZ.
  2. As an example, Goto Tickets Work center and Open any Ticket.
  3. Do required page layout changes.
  4. Adapt -> Assign Page Layout.
  5. Select Tickets in Business Object.
  6. Assign XYZ page layout to a Business Role.

When you logon to system in HTML5 with this Business Role Access, it is working. But In responsive UI, changes are not reflected.

Cause

Since Ticket Screen in RUI is based on Tablet floorplan, you must redo page layout changes and assign to a Business role in Tablet floorplan.

Resolution

Since Responsive UI is based on Tablet floorplan, you must redo changes in Tablet floorplan.

Logon to system with below URL:

https://myxxxxxx.crm.ondemand.com/sap/public/ap/ui/repository/SAP_UI/HTML5/client.html?app.component=/SAP_UI_CT/Main/root.uiccwoc&rootWindow=X&redirectUrl=/sap/public/byd/runtime&sapbyd-agent=TAB

  1. In Adapt -> Edit Page Layout XYZ.
  2. As an example, Goto Tickets Work center and Open any Ticket.
  3. Do required page layout changes.
  4. Adapt -> Assign Page Layout.
  5. Select Tickets in Business Object.
  6. Assign XYZ page layout to a Business Role.

Keywords

KBA , AP-RC-UIF-RT-B , ByD HTML5 Client (not for Cloud for Customer) , How To

Product

SAP Cloud for Customer 1602 ; SAP Hybris Cloud for Customer add-ins 1605 ; SAP Hybris Cloud for Customer add-ins 1608 ; SAP Hybris Cloud for Customer add-ins 1611 ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711