Symptom
You are checking the Changes tab of a record and notice that not all data changes are available.
Environment
- SAP Business ByDesign
- SAP Cloud for Customer
Reproducing the Issue
For the sake of reproduction, we will focus on a property of the Supplier record in Business ByDesign. This behavior, however, applies to other records where change history is available in SAP Business ByDesign as well as in SAP Cloud for Customer.
- Go to the Supplier Base work center.
- Access the Suppliers view.
- Show All Suppliers.
- Locate and open the relevant supplier record.
- Go to the Communication tab.
- Go to the Collaboration sub-tab.
- Here, you are able to change the E-Mail address field.
- Go to the Changes tab and click the Go button.
You are not able to see the change log for the E-Mail address value.
Cause
Not all data change is recorded in the change history. Additionally, the Changes tab in the UI will not display the entire change history in some cases, with certain logs being available only in the backend.
The framework is designed this way due to performance and data payload reasons.
Resolution
This is currently the expected system behavior.
Keywords
Changes, Not Recorded, Change History, Change Log, Performance , KBA , SRD-MD-BP-SUP , Suppliers , How To