SAP Knowledge Base Article - Public

2308023 - Update custom report version in scheduled jobs

Symptom

  • Scheduled custom report disappeared after uploading a new one with the same title.
  • When going to Reports > Saved reports tab, the following error message is displayed:

 "The parent report has been deleted from the system and is no longer available. You can still preview previous results".

Environment

SAP SuccessFactors Learning

Cause

Anytime an admin imports a report for which another one of the same name already exists, the system treats the report as a new version of an existing report. This means that once published, even though changes made were minor, the system removes all links to the previous version – including saved and scheduled reports. This can sometimes cause performance issues accessing the report Jobs tab if there were many occurrences of the report scheduled.

We can only have a saved or scheduled report job for a report that is in published status.

Resolution

  1. For saved reports displaying a warning message, use the trash icon to delete those manually or contact Professional Services to have them removed via scripts.
  2. To prevent further issues, refer to the below guidelines when importing a new version of a custom report:

Administrators can decide whether they want the imported report to be a new version or if they want to update the existing version.

TIP: If your changes are minor or cosmetic, we recommend that you update the existing version but if you change the report logic then it is better to import as a new version and create new scheduled jobs.

Scenario 1: "Create New Version"

  • Scheduled Reports on previous version should no longer run.
  • No edit option on the schedule (schedule should be automatically cancelled)
  • New scheduled or saved report must be created

Scenario 2: "Update Current Version"

  • Scheduled Reports still run, pointing to updated file.
  • Schedule can be updated.

Please note that sometimes a particular job may not not updated during this process and continues to use the older version - therefore not returning data or showing errors. In this case, please delete the job and create a new schedule to ensure it is using the latest report version.

Keywords

custom report update; versioning of custom report; scheduled custom report; saved custom report; LRN-9706; import new version of custom report; The parent report has been deleted from the system and is no longer available; You can still preview previous results; , KBA , LOD-SF-LMS-CRI , Custom Report Issues , LOD-SF-LMS-BCJ , Assign (bulk), Add/ Delete Sub/ Cur, Revise, Import , How To

Product

SAP SuccessFactors Learning all versions