Symptom
An event reason has been set up for Concurrent Employment, but it is only showing for users with no job information.
Expected Behaviour: Concurrent Employment Event Reason should be showing for all users
Reproducing the Issue
Event Reason has been set up with “Event” set as “Hire”, and “Employee Status” set to “Active”, as outlined in the Concurrent Employment Handbook
View and Edit Permissions have been selected under Manage Permission Roles > Employee Data > Event Reason > Add Employment.
However when Selecting Take Action > Add Employment Details > User’s with Job information do not see the Event Reason.
Cause
The Object Country has the Event Reason selected under Associations
Navigate to Admin Center > Configure Object Definition > Object Definition > Select Country:
Resolution
Add the Event Reason to each country.
Navigate to Admin Center > Manage Data > Country > Select the Country where you want to add the Event Reason.
Afterwards the Event Reason should be available for all employees who's Legal Entity is in the Country.
Keywords
Concurrent Employment
Event Reason
, KBA , LOD-SF-EC-CON , Concurrent Employment , Problem