Symptom
- Unable to connect to Salesforce.
- When attempting to connect to Salesforce.com from Lumira Desktop, it fails with the error:
"Driver error: Failed to send request to https://login.salesforce.com/services/Soap/u/27.0"
Environment
- SAP Lumira Desktop 1.x
- Salesforce.com
Reproducing the Issue
- In SAP Lumira Desktop, select "File - New"
- In the window "Add new dataset", select "Query with SQL", and click "Next"
- Select "Salesforce.com - JDBC Drivers", and click "Next"
- Enter the user name and password to connect to Salesforce.com, and click "Connect"
It will fail to connect and generate the error:
"Driver error: Failed to send request to https://login.salesforce.com/services/Soap/u/27.0"
Cause
- It fails because there is a Proxy configured on the network to connect to the Internet, and the proxy setting was not added to the Salesforce.com connection in Lumira.
Resolution
- Add the proxy information to the Salesforce.com connection in Lumira Desktop.
- Contact your IT Administrator to obtain your network proxy information.
( Proxy Address, port number, user and password if any )
- Create a connection to Salesforce.com from SAP Lumira Desktop.
- In the Salesforce.com login screen, enter the Salesforce user and password.
- Still in the login screen, under "HTTP Proxy" in "Proxy Address", wnter the proxy name with the port number separated by a column. The format is: <Proxy Name>:<Proxy Port>
For example:
If the proxy name is: MyProxy, and the port number is: 8000, then enter in Proxy Address, enter: MyProxy:8000
- Enter the proxy User Name and Password, if any, then click "Connect"
You will then be able to successfully connect to Salesforce.com from SAP Lumira Desktop.
- Note:
To know your company network proxy configuration, it is best to contact your IT Administrator, but a second suggestion will be to verify if the proxy information is available in Internet Explorer (IE). To verify the proxy setting in Internet Explorer:
- Launch Microsoft Internet Explorer, and select "Tools - Internet Options"
- In the "Internet Options" window, under the tab "Connections", click the button: "LAN Settings"
- In the "Local Area Network (LAN) Settings" window, if a proxy setting was added in Internet Explorer, it will display it in the format:
http://<Proxy Name>:<Proxy Port>
Take the proxy configuration information found to connect to Salesforce.com in Lumira Desktop.
Keywords
lum, sforce, Salesforce , KBA , BI-LUM-DIS , Lumira Desktop/Discovery , Problem
Product
SAP Lumira, desktop edition 1.0