Symptom
- Fails to logon to Salesforce from Lumira.
- Used to be able to connect to Salesforce.com from Lumira.
- When attempting to connect to Salesforce.com from Lumira Desktop, it fails with the error:
"Driver error: TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using https."
Environment
- SAP Lumira Desktop 1.x
- Salesforce.com
Reproducing the Issue
- In SAP Lumira Desktop, select "File - New"
- In the window "Add new dataset", select "Query with SQL", and click "Next"
- Select "Salesforce.com - JDBC Drivers", and click "Next"
- Enter the user name and password to connect to Salesforce.com, and click "Connect"
It will fail to connect and generate the error:
"Driver error: TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using https."
Cause
- The reason it fails to connect to Salesforce.com, it is because Lumira Desktop uses TLS 1.0 encryption to communicate with Salesforce.com, but Salesforce has disabled TLS 1.0 for security reason at the beginning of 2016. And it is now required for any external application to use TLS 1.1 or higher.
- For reference, see the Salesforce Knowledge Article 000221207
- The issue has been tracked under SAP Note 2367820
Resolution
- There is currently no product update at this point that resolved this issue.
Keywords
lum, tls 1.0, SForce , KBA , BI-LUM-DIS , Lumira Desktop/Discovery , Problem
Product
SAP Lumira, desktop edition 1.0