Symptom
Unable to change the status schema after a Document Type that has been created. It is also not possible to delete an existing document type.
Reproducing the Issue
- Go to Business Configuration work center
- Select Open Activity List
- Search and open the activity tickets for customer support
- Select Maintain documents, not possible to delete document type (custom document type starts with Z)
- Select Maintain Status schemas, not able to add or delete status schema
Cause
It is not possible to delete the Document type once it is saved .
Resolution
But you can add new Document types & Status schemas .
For Maintain Document Types, if the Status schema is made editable , and it is changed - this would mean ,the schema needs to be changed for existing documents of the same type. And this is currently not supported.
So the only way here is to create a new Document type & assign it to Custom status and then create new Tickets with this new document type .
Keywords
KBA , LOD-CRM-SRP , Service Request Processing , How To