Symptom
After that attempt the item would appear as "LOCKED OUT" in the user's learning plan.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Learning
Cause
An item has the setting "Lock Item" for "Upon Failure" setting with a maximum number of attempts in "Number of Failed Attempts Allowed for an Item".
Resolution
Depending on the scenario, there might different ways to unlock the item to allow the user one more attempt. Please follow the steps below in order and only move to the next if the previous one hasn't unlocked the item:
Step 1 - If the item is still in the user's learning plan, it's possible to enable the user for one more attempt:
- Learning Administration > People > Users > Search for the affected user's record > "Assigned Items" tab > Search for the item that needs to be unlocked > Click the three dots > Click "Object Details" >
- Select the object that you want to provide access to the user >
- Check "Has Access" and hit "Apply Changes" >
- The item would be unlocked now for the User to access it once.
Step 2 - If the "Object Details" option is not available at the affected item, or if the item was removed from the user assigned items after it is unlocked and reassigned, the option "Object Details" won't be available as well (as it is a new assignment, and the item will still be in "LOCKED OUT" state on the user's learning plan). So, when the "Object Details" is not available:
- Navigate to the item's record > "Online Content" tab > Settings > Switch (disable or enable) a few options, e.g.: "Add to History on Completion of All Content" and "Add to History on Pass" (as both are enabled) DO NOT REASSIGN THE ITEM YET >
- Switch the settings as they were > Save >
- It will pop up a wizard to allow the item to be reassigned to users >
- Reassign the item to the affected user >
- Now at the user's record > follow Step 1 above.
Step 3 - There is an edge case where the steps above might not be enough. In this case you may need to remove the learning history recorded for the failure:
- Learning Administration > Manage User Learning > Edit Learning History > Search for the affected user and item >
- Open the event of the failure in the Edit mode >
- Hit "Delete".
See Also
2420626 - Exam is not getting locked when the number of maximum tries is set to two
2328118 - Using the Content Reassignment Assistant/Wizard to reassign an item to user(s)
2316902 - Item showing as locked-out in the user's learning plan
Keywords
locked, out, learning plan, item, no, content, object, administration, learning, exam, assessment, object, detail, has, access, lock, failure, fail, attempt , KBA , LOD-SF-LMS-ITE , Items , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS-ASB , Assessment Builder , Problem