Symptom
This is a collection of useful Knowledge Base Articles related to Ad-Hoc Reports.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
Reproducing the Issue
Before opening an case with Product Support, perform the following sanity checks on your configuration/data, bearing in mind most Application or BIRT/JAVA errors are caused by one or more configuration issues:
Employee Central Ad Hoc Reports - list of EC Ad Hoc reports = KB article 2080162 - Employee Central: Ad Hoc Report Types Explained
- Checked that all fields (Columns) in the related element (Column Set) are configured according to the related Implementation Handbook and Data Object Tables handbook
- Correct permissions are granted to the end user to be able to use the report (as specified in the Implementation Handbook)
- Has the related Column/Column Set configuration changed recently? Can the recent change be un-done so re-testing can be performed?
- Can the issue be reproduced for just 1 or multiple end users? If the issue is reproducible for all it is still likely to be a configuration issue. If it seems to be related to 1 or a small admin population - the next step is to check and verify the permissions are correctly granted.
Checked the FAQ below?
Cause
Tips & Tricks
Below are some tips and tricks recommended by Product Support, which you should consider first before opening a Support case
FAQ Index
Configuration Issues
You can usually determine there is a Configuration Issue preventing EC Ad Hoc Reports from running when you try to run one of the reports, and you encounter a JAVA error message pop-up similar to that below. This usually means one or more fields/objects are configured incorrectly, causing the schema load to fail.
BIRT Errors
- 2272691 - Unable to run Adhoc report with domain "Person and Employment Export report"
- 2080032 - EC Ad Hoc is only showing pick list id's and not the descriptions
- 2291656 - Ad Hoc report - calculated columns
- 2250749 - Adhoc reports showing wrong currency for Pay Component Group Sums
- 2231540 - Employee data missing in ad-hoc reports
Employee Central Ad Hoc Reports - FAQ & Tips
Please refer to the below article, to understand the typical uses of the Employee Central Ad Hoc reports
- 2080162 - Employee Central: Ad Hoc Report Types Explained
- 2155392 - Adhoc Report TimeStamp Configuration
- 2080162 - Employee Central - Ad-Hoc Report Types & Permissions Explained
- 2288908 - How to change the format of Date fields in EC reports
- 2092850 - How to make changes to Employee Data on mass via Import
- 2266216 - How to Export Employee Central Data for Import Activities
- 2080152 - How can I tell when Employee data was entered or last amended, what changed and by whom?
- 2550241 - Report on Global Assignment Fields
- 2265424 - Does Ad Hoc Reporting support extraction of Dependent Portlet data?
- 2274688 - How to report on Workflows
- 2226656 - MDF Position Data in Table (Ad hoc) Reports Displays InternalId for Foundation Object Columns - EC
- 2099893 - Ad Hoc Person and Employment Audit report is not returning expected data
- 2631131 - Employee Central: Ad Hoc Reports take a long time to execute or are timing out
Pay Component Group Sums Sync
- 2080171 - Employee Pay Group Sums do not retrieve any data when selected in Ad Hoc Reports
- 2345923 - HRIS Pay Component Group Sums Sync Job Fails Repeatedly
Resolution
When opening a support case for EC Ad Hoc Reports, please ensure the following information is attached to the case:
- Attach the Data Models related to the issue: Succession Data Model, Country Specific Succession Data Model, Corporate Data Model and Country Specific Corporate Data Model
- Screenshot of the Error Message - also copy/paste the content of the error message pop-up to the case (for JAVA errors or Application Error errorIds this is crucial)
- Timestamp - Copy/paste the text from the "Show version information" popup into the case
- Is the issue replicatable for all users or just some/one?
- Granted users Role-Based Permissions settings
- Attach the View Permission Role output (right click on the page and Print to PDF)
- Please provide detailed steps to reproduce the issue you are encountering - preferably including screenshots - Please make sure that the screenshot is full screen (meaning to show complete web page view). Include:
- Name or UserID of user encountering the issue
- Is Proxy involved? If so the Name or UserID of the user who is being proxied
- When creating an issue, please answer following questions (answer whichever is applicable, if a question doesn't apply in a scenario then answer "Not Applicable"):
- Did this issue start recently?
- Was the same feature or functionality working before?
- Is the issue reproducible for other users?
- If the issue is realted to a Picklist or Object field, then please attach an export of the Picklist/Object related data
See Also
2315109 - Employee Central - Tips & Tricks from Support
Keywords
SAP SuccessFactors EC adhoc report errorId, Userful information, FAQ , KBA , LOD-SF-EC-REP , Reporting Data (EC core only) , LOD-SF-EC-ADM , Admin Tools (EC Core only) , How To