Symptom
- How do I update user Job History Information record via Import in Full Purge mode?
- How do I correct an Employees Job Info Record?
- Error message during import:
The hire record should always be the first record for a user. Continuing with this import will result in the recruit record not being the first record anymore
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Go to Admin Tool then Import Employee Data
- Select Job History and Full Purge
- Select import file
- Click on Validation Import Data
- Result: Import failed
Error message: The hire record should always be the first record. Continuing with this import will result in the hire record not being the first record anymore.
Cause
- Wrong Data stored in the database
- User has rehired record without been Terminated
- User: rehired record in Test user Job History Information
- User: No Termination Record in Test user Job History Information
- The Job History import csv file contains identical record as existing database
Resolution
Note:
- When following the below guidance, the expected outcome is that the existing data is purged and replaced with fresh data from the Import file. For example, if you have 10 records for the user, and you perform a Full Purge import with 3 records, only the 3 records will remain after the import is completed.
- When deleting employee's EC data through import, compensation information should be deleted before removing job information.
Step 1: Run Adhoc Report
-
Go to Analytic then Adhoc Report
-
Create new Report
-
Select sub domain: Person and Employment Export
-
In Column, Select only column Employee Job Infos
-
Filter Test user
-
Save
-
Back up your report into Your Desktop (will be used as a Backup)
Step 2: Export Blank Template
- Go to Import Employee Data
- Download Template
- select Job History
- In Select Country / Region: select country base on test user legal entity
- Generate Template
Important Note: Select Country / Region
- Multiple countries can be selected in the 'Select Country' dropdown present in Download Imports template
- Based on enhancements made in 1805, Users can download a template specific to a country from the newly introduced “Select a Country” dropdown. On choosing a country, for example, USA, the system will automatically list all the data fields from the Succession data model and the fields configured in the Country-specific data model for the selected country USA.
- This request is to allow multiple countries to be selected, so that data fields from Sucession Data Model or CSF Data Model corresponding to the selected countries can be downloaded in one attempt.
Step 3: Build Your Job Information Import file
- Fill Your Blank template base on Your Job Information Report
- Make sure the end date column is not populated
- When adding more than one record, please make sure the rows are inserted in ascending order (first row will be the older one)
Step 4: If the import csv contains identical record as existing database
- Go to Admin Center > Company System
- Click on Company System and Logo Settings
- Scroll down and disable Suppress update of identical records during Employee Central import for supported entities
- Save ( Note:-The Suppress update of identical records during Employee Central import for supported entities setting in Company System and Logo Settings page will reach end of maintenance on June 2, 2023 and will be deleted from the code by November 17, 2023.) Now not available under Company System and Logo Settings.
Refer the below updated Link for more information:
Suppress Switch in Company System and Logo Settings is Deleted | SAP Help Portal
Important Information: Import Engine Parameters
In Admin Tools, come to Company System and Logo Settings, there are 5 options are import related:
- Enable rules execution during Job Information import
Only one entity Job Information supports rule execution when doing imports
For more information please refer to the KB Article 2615455 - Job Information: Rule and Propagation on Import switches in Role-Based Permissions from Company System and Logo Settings - Enable Forward Propagation of Job Information Data for Inserts in Incremental Imports
For more information please refer to the KB Article 2615455 - Job Information: Rule and Propagation on Import switches in Role-Based Permissions from Company System and Logo Settings
- Attach data with email for Import/Export jobs
It is meaningless if the import csv contains identical record as existing database - Execute Business Rules and Propagation Against NO_OVERWRITE.
For more information please refer to the KB Article 2615455 - Job Information: Rule and Propagation on Import switches in Role-Based Permissions from Company System and Logo Settings
Step 5: Run a Job Information Full purge import for the user
- Review the populated import template to ensure all data are correct
- If the fields in the AdHoc report and import template match, copy and paste can speed up this portion of the process
- Take note of the effective dates of your records to ensure there is no overlap
Make sure the end date column is not populated
- In Admin Center > Import Employee Data, for example, select Job History
- Choose the Full Purge option checkbox
- Choose the file created in step above and select Validate to confirm the information is correct
Notes:
- A full purge import will erase all records and replace them with the data in the import file
- Do Not Add end date into your New Import File
Remarks: Employee Central Import Guide
- Full Purge - Job Information Import
- Select import type: Job History with Full Purge option. The Full Purge option will delete this user and insert a record that you want to see into user Job History
- Incremental Load - Job Information Import
- Select import type: Job History with Incremental Load option. This option only reflects the change data (no overwrite).
- When importing data for the Job Information, the field 'Time Recording Variant' may give validation error if the text value is used.
- What happens is that the code needs to be set instead, for further details please check KB article 2338762 - Time Recording Variant And Default Overtime Compensation Variant Not Updating Through Mass Change
FAQ - Additional Information
Q) Where can I get information on this from the Guide?
A) Guide: Managing Mass Changes in Employee Central - Chapter- Centralized Services for Employee Data Imports
See Also
- 2338762 - Time Recording Variant And Default Overtime Compensation Variant Not Updating Through Mass Change
- 2615455 - Job Information: Rule and Propagation on Import switches now migrated to Role-Based Permissions from Company System and Logo Settings
- 2494885 - Correct or Update Pay Component Recurring or Pay Component Non Recurring Information record via Import in Full Purge mode
- 2413486 - Correct or Update Compensation Information record via Import in Full Purge mode
- 2489526 - Correct or Update Job Relationships Information record via Import in Full Purge mode
- 2239428 - How to remove an unintended Termination of an Employee
- 3062823 - Error: The manager [NAME] for user [NAME] does not exist or was not yet hired as of yyyy-mm-dd (date) appears during Job History Import
- 2565955 - Supervisor ID Does Not Exist or is Not Active During Import
- 2315276 - Employee Central Implementation - Data Imports FAQ
- 2092850 - How to make changes to Employee Data on mass via Import - Employee Central
- 2346500 - How to Enhance System Performance During Imports in Employee Central
Keywords
SF success factors, EC, Purge mode, Import Employee central, Incremental Load, termination , KBA , LOD-SF-EC-JOB , Job Information , LOD-SF-EC , Employee Central , LOD-SF-EC-EDP , Import Employee Data (EC Core only) , LOD-SF-INT-EC , Employee Central SFAPI & OData Entities , How To