Symptom
This is a collection of useful articles related to Role-Based Permissions.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
Reproducing the Issue
Before opening an case with Product Support
Please be sure that before you open a support case with Product Support, you have performed the following sanity checks on your configuration/data - bearing in mind most issues are due to a configuration issue -:
- Does the same issue occur if the user is removed from the current Permission Roles and granted to a separate Permission Role that has all of the permissions the user would require?
- View User Permission: Are you able to see what permissions the employee has actually been granted via Admin Center > View User Permissions (to see a roll-up of all Permissions granted to the user)
- User Role Search: If it is a specific issue such as one user can see data for another user that they should not - have you verified whether the user indeed has permission granted to the target user by analyzing the result of the Admin Center > User Role Search tool?
- Can the issue be reproduced for just 1 or multiple users?
- If the issue is reproducible for all users, it is still likely to be a configuration issue.
- If it seems to be related to 1 or a small user population - the next step is to check and verify that the data is correct for the user (as the filters used to build Target Populations are also based on Effective Data for the target employee).
- Have you allowed ample time for Permission Roles/Groups to be updated after making a configuration or data change? (bearing in mind that nothing is instant, and can take up to 60 minutes to refresh)
Checked the FAQ below?
Cause
Tips & Tricks
Below are some tips and tricks recommended by Product Support, which you should consider first before opening a Support case
FAQ Index
Role-Based Permission Considerations
Next we will look at an overview of how RBP works with Employee Central as well as some general FAQ's regarding RB issues related to EC -:
- Basic Overview of Role Based Permissions (RBP) - Employee Central
- How to grant a user Administrator privilages
- Add New Employee wizard & RBP (also see Why RBP Permissions/Group is Not Updating for a New Hire? (Using the Data Inspector tool))
- How to Exclude Users/Populations from a Permission Group (Target Population)
- Does Adhoc reporting uphold permissions set in RBP on specific fields
- New Hire / Rehire wizards - Field level permissions are ignored
- Adding Filter’s to the Target Population Section in Manage Permission Role
Troubleshooting Tips & Tricks
Finally, some general troubleshooting advice when it comes to Role-Based Permissions in relation to Employee Central.
- Why RBP Permissions/Group is Not Updating for a New Hire? (Using the Data Inspector tool)
- Edit Future Dated New Hires in Employee Central
- Unable to view Person/Employment info page of Future dated hire
- Employee Profile fields do not return full list of Object values when creating Permission Groups
- Effective dated fields not displayed in Role based permissions
- Role Based Permissions to the Field Date-of-Death
- RBP for Alternative Name Fields
- Event Reason Persmissions
Resolution
When opening a support case for Role-Based Permissions, please ensure the following information is attached to the case
- Attach the Succession Data Model and Country/Region-Specific Succession Data Model being used at the time the case is raised
- Screenshot of the Permission Role configuration (View User Permissions)
- Screenshot of the "User Permission Role" check you have performed
- Screenshot of the related Permission Group definitions (Manage Permission Groups)
- Permission Role name and Permission Group name (exactly as defined in the UI)
- Attach the Data Models related to the issue: Succession Data Model and Country/Region-Specific Succession Data Model
- When creating an issue, please answer following questions (answer whichever is applicable, if a question doesn't apply in a scenario then answer "Not Applicable"):
- Did this issue start recently?
- Was the same feature or functionality working before?
- Is the issue reproducible for other users?
- If the issue is related to a Picklist or Object field, then please attach an export of the Picklist/Object related data
See Also
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2315109 - Employee Central - Tips & Tricks from Support
Keywords
RBP, Employee Central 2.0, Permissions, Security, role-based permissions, permission groups, RBP, FAQ , KBA , LOD-SF-EC-ADM , Admin Tools (EC Core only) , LOD-SF-EC , Employee Central , How To