Symptom
Required Survey Questionnaire is not triggered when Item is completed.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Associate a Questionnaire Survey to an Item >
- Assign the Item to a user >
- Once the Item is completed, the survey is not sent to the user as expected.
Cause
This can occur if one of the following is not set properly:
- Required for Item Completion at the Survey level is not enabled
- Required for Item Completion at the Item level is not enabled
- The necessary settings are not enabled for the Completion Status to trigger the survey
Resolution
How to set each of the Options to ensure that the Evaluation Surveys are sent out:
- Setting at the Item level:
- Logon to Learning Admin >
- Navigate to Learning Activities > Items > Surveys tab >
- Make sure Required for Item Completion is enabled along with a value in Days to Complete.
- Setting at the Survey level:
- Logon to Learning Admin > Content > Surveys
- Search and open the Survey > Options tab
- Make sure Required for Item Completion is enabled along with a value in Days to Complete.
- Completion Status setting:
- Logon to Learning Admin
- Check which Completion Status the Item is using
- Navigate to Learning Administration > Learning Activities > Items >
- Search and open the Item >
- Go to the Online Content tab > Online Content Settings (gear icon) > Check the Completion Status value.
- Go to References > Manage Users Learning > Completion Status >
- Search for the Completion Status that you observed in point (a) and open it
- Make sure all the checkboxes are enabled for the Surveys Assignments and if not, please enable all and then choose Apply Changes
- - Include learning events with this completion status for Item Evaluation: User Satisfaction Surveys Assignments
- - Include learning events with this completion status for Follow-up Evaluation: Application of Learning Surveys Assignments
- Assign the course to the users again and see the Survey working properly.
Keywords
evaluation, follow-up, satisfaction, assign, questionnaire, survey, item, not, triggered, working, completing, without, sent, notification email , KBA , LOD-SF-LMS-ITE , Items , LOD-SF-LMS-COR , LMS Core - Items, Catalog, Curricula , Problem