Symptom
User gets error message: "Please Enter a Valid Contract Account Category" when trying to create new contract account.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Utilities work center.
- Go to the Business Agreement view.
- Click the New button.
- Fill out the mandatory information (for example: Account, Agreement Name, Agreement Class, Payment Terms).
- Click Save and Close.
Error: "Please enter a Valid Contract Account Category".
Cause
Business Agreement and Service Location workcenters are not relevant for B2C scenarios. For B2C scenarios, the Business Agreement and Service Location work centers have to be deselected for the users.
Resolution
Unassign both the workcenters for the user and use the Contract Accounts work center for B2C scoped scenarios.
If you need to create a new contract account, search the customer/account and navigate to the Contracts facet. Alternatively, navigate to Utilities 360 facet and create contract account from there.
Keywords
Ticket, Service Request, Utilities, Valid, Contract Account, Category, New, Account, , KBA , LOD-CRM-IND-UTL , Utilities , How To