Symptom
This is a collection of useful articles related to Apprentice Management.
Environment
Reproducing the Issue
Before opening an case with Product Support
Please be sure that before you open a support case with Product Support, you have performed the following sanity checks on your configuration/data - bearing in mind most issues are due to a configuration issue -:
- The feature is correctly enabled, as described in the related Implementation Handbook
- Correct permissions are granted to the administrator/end-user to be able to use the tool (as specified in the Implementation Handbook)
- Has the configuration changed recently?
- Was it working before the recent changes?
- Can the recent change be un-done so re-testing can be performed?
- Can the issue be reproduced for just 1 or multiple admins?
- If the issue is reproducible for all it is still likely to be a permissions issue.
- If it seems to be related to 1 or a small admin population - the next step is to check and verify the permissions are correctly granted.
- Is the data correct? (Ensure that any recent configuration changes you have made have not caused any data inconsistencies)
- HHave you verified that, according to the related Implementation Handbook, the feature is configured according to Best Practices recommended in the handbook?
Cause
Tips & Tricks
Below are some tips and tricks recommended by Product Support, which you should consider first before opening a Support case
FAQ Index
Object Configuration
- 2333914 - Unable to activate department object
Role-Based Permissions
- 2465690 - Apprentice Management Permissions - Unable to grant RBP - "There are no secured objects in this category."
Errors
- 2625482 - Manage Apprentice Department not Loading
- 2556589 - Apprentice Management Home Tile Always Loading on Homepage for on-Site Supervisor
Resolution
When opening a support case, please ensure the following information is attached to the case
- Screenshot of the Error Message - also copy/paste the content of the error message to the case if possible (for JAVA errors or errorIds)
- Timestamp - Copy/paste the text from the "Show version information" popup into the case
- Is the issue replicable for all users or just some/one?
- Screenshots of granted users Role-Based Permissions settings for Advances
- Screenshots of UI configurations
- Please provide detailed steps to reproduce the issue you are encountering - preferably including screenshots - Please make sure that the screenshot is full screen (meaning to show complete web page view)
- When creating an issue, please answer following questions (answer whichever is applicable, if a question doesn't apply in a scenario then answer "Not Applicable"):
- Did this issue start recently?
- Was the same feature or functionality working before?
- Is the issue reproducible for other users?
- If the issue is related to a Picklist or Object field, then please attach an export of the Picklist/Object data
See Also
Keywords
Apprentice Management, Employee Central 2.0, PP3, error, FAQ , KBA , LOD-SF-EC-APM , Apprentice Management , How To