Symptom
This is a collection of useful Knowledge Base Articles related to Name Format.
Environment
Reproducing the Issue
Before opening an case with Product Support
Please be sure that before you open a support case with Product Support, you have performed the following sanity checks on your configuration/data - bearing in mind most issues are due to a configuration issue -:
- The feature is correctly enabled, as described in the related Implementation Handbook
- Correct permissions are granted to the administrator/end-user to be able to use the tool (as specified in the Implementation Handbook)
- Has the configuration changed, recently?
- Was it working before the recent changes?
- Can the recent change be un-done so re-testing can be performed?
- Can the issue be reproduced for just 1 or multiple admins?
- If the issue is reproducible for all, it is still likely to be a permissions issue.
- If it seems to be related to 1 or a small admin population - the next step is to check and verify if the permissions are correctly granted.
- Is the data correct? (Ensure that any recent configuration changes you have made have not caused any data inconsistencies)
- Have you verified that, according to the related Implementation Handbook, the feature is configured according to Best Practices recommended in the handbook?
Cause
Tips & Tricks
Below are some tips and tricks recommended by Product Support, which you should consider first before opening a Support case
FAQ Index
Configuration:
- 2274066 - How to use Name Format functionality in Employee Central
- 2297189 - Name Format: Where in the UI is Name Format Respected?
- 2317335 - Name Format support in Employee Profile and User Directory - Employee Profile
- 2504412 - Formal Name Field Not Visible During New Hire Wizard
- 2317347 - How to enable Name format for People profile and Directory Search
Data Issues:
-
2295729 - Name Format: Changing the Name Format Assigned to Legal Entity will not dynamically update Formal Name for Employees
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2297189 - Name Format: Where in the UI is Name Format Respected?
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2295729 - Name Format: Changing the Name Format Assigned to Legal Entity will not dynamically update Formal Name for Employees
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2317335 - Name Format support in Employee Profile and User Directory - Employee Profile
Resolution
When opening a support case, please ensure the following information is attached to it:
- Screenshot of the Error Message - also copy/paste the content of the error message to the case if possible (for JAVA errors or errorIds);
- Timestamp - copy/paste the text from the "Show Version Information" popup into the case;
- Is the issue reproducible for all users or just some/one?;
- Screenshots of granted users Role-Based Permissions settings for Advances;
- Screenshots of UI configurations;
- Please provide detailed steps to reproduce the issue you are encountering - preferably including screenshots. Please make sure that the screenshot is full screen (meaning to show complete web page view, not just parts of it);
- When creating an case, please answer the following questions (answer whichever is applicable, if a question doesn't apply in a scenario then answer "Not Applicable"):
- Did this issue start recently?
- Was the same feature or functionality working before?
- Is the issue reproducible for other users?
- If the issue is realted to a Picklist or Object field, then please attach an export of the Picklist/Object data.
See Also
- 2315109 - Employee Central - Tips & Tricks from Support
Keywords
Name Format, Employee Central 2.0, FAQ, Tips & Tricks, Enable, Implement, Configure, How To, Personal Information, Formal Name, Search, Best Practices, Recommendations , KBA , LOD-SF-EC-PER-PRS , Personal Info - Config, Rules, RBP, UI , LOD-SF-EC , Employee Central , LOD-SF-EC-PER , Person Data (All Person Data Types) , How To