Symptom
Cannot update the Manager Field for a User in Successfactors
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Navigate to Manage Users
- Select User
- Change Manager
- Click Save
- Manager Field clears the value
Cause
This is caused by the user's account that is altering the Manager field value not having the appropriate Role Based Permission to select the new value
Resolution
The user changing the value of the Manager field must have the "User search permission" in RBP, as the user will not be able to find any users to select the Manager from otherwise
See Also
Keywords
Manager Users, Search Permission, cannot add update manage users field Role Based Permissions , KBA , LOD-SF-PLT , Platform Foundational Capabilities , Problem