SAP Knowledge Base Article - Public

2321141 - Disqualified Candidates Not Receiving Delayed Emails - Recruiting Management

Symptom

  • Disqualified candidates are not receiving the notification configured to be sent after a specific date/time.
  • The notification was not triggered upon checking the Correspondence portlet on the Job Application.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting

Reproducing the Issue

  1. Go to Admin Center > Manage Recruiting Settings
  2. The option 'Delay Emails to Disqualified Candidates(in hours)' was configured to send the notification after a specific time (e.g. 72 hours)
  3. Go to the Job Requisition
  4. Place the candidate in a disqualification status 
  5. After 72 hours, the email was not launched by the system

Cause

The scheduled job "Candidate Status Mail Delay" stopped running in Provisioning. It could have failed due to invalid job owner.

(For Partner/Support only:) You can check this in Provisioning > Monitor Jobs by selecting the Job Type "Candidate Status Mail Delay".

IMPORTANT: The "Auto-Disqualified" status is a system status and is also a Disqualification status. If a recruiting user has established a set of pre-screening questions on the requisition that have disqualifying questions or a passing score requirement, applicants who fail the pre-screen are automatically placed into the "Auto-Disqualified" status of the pipeline, and will be subject to the mail delivery delay.

Resolution

This specific job is not configured in Provisioning, but instead is scheduled automatically based on the settings of Delay Emails to Disqualified Candidates in Manage Recruiting Settings.

In order to have the job running again, you need to reset the settings:

  2019-04-02_9-23-04.png

  1. Go to the Admin Center > Manage Recruiting Settings
  2. Under 'Return Email Address Information', uncheck 'Delay Emails to Disqualified Candidates (in hours)'
  3. Clear all the information within the fields:
    • Delay Emails to Disqualified Candidate (in hours)
    • Don't send emails older than (in days)
    • Job Owner
  4. Save the changes
  5. Configure the feature again and save the changes
  6. The Provisioning job will start again

If the email is still triggered upon checking the Correspondence portlet, please raise a Support ticket and mention this KB article.

See Also

KB article 2705381 - Delay Mails to Disqualified Candidates Behavior When the Candidate is Moved to Other Status

Keywords

sf, success factors, RCM, e-mail, notify, notification, Disqualified Emails, Delayed Emails, Disqualified Delayed Emails, Delay Emails, Candidate Status Mail Delay, Return Email Address Information, Delay Emails to Disqualified Candidates , KBA , LOD-SF-RCM , Recruiting Management , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem

Product

SAP SuccessFactors Recruiting all versions