Symptom
You get the error "The Certificate is Already Assigned to User _ABCXYZ" when trying to upload the HCI client certificate in the inbound communication arrangements.
_ABCXYZ is a communication user.
Reproducing the Issue
- Go to the "Administrator" WoC.
- Go to the "General Settings" View.
- Click on the Communication Arrangements hyperling under the Integration section.
- Select and open the relevant inbound Communication Arrangement.
- Click on View All.
- Click on Technical Data.
- The Authentication Method would be SSL Client Certificate.
- User ID: _DEFXYZ.
- Click on the button: Edit Credentials.
- Select the Certificate Tab.
- Click on the button Upload Certificate.
- brows and select the HCI client certificate
- When uploading you get the error: "Certificate is Already Assigned to User _ABCXYZ"
Cause
The error is expected system behaviour because the HCI client certificate is already mapped to the communication user _ABCXYZ and can not be assigned to _DEFXYZ.
To check please:
- Go to the Administrator WoC.
- Then select the Communication Certificates View.
Here you will see that the certificate is already mapped to the communication user _ABCXYZ.
The issue is encountered when you want to connect or integrate multiple external system with C4C as only one hci client certificate is offered to customers when getting your HCI tenant.
If you need to connect more than one system you need to follow the same process for signing a new client certificate.
Resolution
For that, you need to provide the below details for creating CSR for new certificate which then the CSR would be provided to you for signing.
- Common Name (CN): (The Domain Name should be that of customer)
- Organization Unit (OU):
- Organization Name (O):
- Locality Name (L):
- State Name (ST):
- Country (C):
- Email (E):
Keywords
KBA , LOD-CRM-EMP , Employee , How To