SAP Knowledge Base Article - Public

2323556 - "The launcher is exited with error" message when opening Analysis workbook from BI Launchpad

Symptom

When opening Analysis workbooks from BI Launchpad or CMC, MS Excel is opening blank and there is a message as shown below:

AO 1.x AO 2.x

The launcher is exited with error, see log file for more details. 
Addin returned an error. Check logfile of the addin!

launcher_exited.png

The launcher exited with errors, see log file for more details.
Addin returned an error. Check logfile of the addin!

AO 2x error.gif

The Analysis Office trace file starting with AO_Trace (see note 2129389) contains the error "Error checking BOE system".

The launcher file with extension ".sapaox" which is being downloaded from BI Launchpad/CMC contains the wrong server information (e.g. server name, port and/or scheme).

This can be confirmed by opening the ".sapaox" file in any text editor (e.g. Notepad) and checking the server information:

  1. Click to view the Analysis Workbook in BI Launchpad/CMC;

    view.png
  2. Save the file instead of opening it;

    save.png
  3. Go to the file's location and open the ".sapaox" file with any text editor;

    openwith.png
  4. Confirm that the server information is not correct.

Environment

SAP Analysis for Microsoft Office

Reproducing the Issue

Open Analysis workbooks from BI Launchpad or CMC

Cause

If BOE version is lower than the following versions:

  • 4.1 SP5 Patch 6
  • 4.1 SP6 Patch 1
  • 4.1 SP7 Patch 0

Then the wrong server information on the launcher file may be caused by Load Balancer, Web Dispatcher or Reverse Proxy.

If BOE version is higher or equal than the versions above, then the wrong server information on the launcher file may be caused by wrong Web Service URL defined in CMC.

Resolution

  1. Make sure your BI platform version is higher or the same as below:
    • 4.1 SP5 Patch 6
    • 4.1 SP6 Patch 1
    • 4.1 SP7 Patch 0

    See SAP note 2169593 - Incorrect Connection Server details in Analysis Office for MS Excel launcher file from BI Launchpad

  2. Make sure your Web Service URL is correctly defined in CMC:
    • Go to BI CMC > Applications > Web Service > Properties;

      Webservices.png

    • Make sure the "Access URL" is correctly defined:

      acessURL.png

      This is the Web Service URL that AO will try to access when opening Analysis workbooks from BI Launchpad / CMC.
      Make sure the "server" and "port" are correct. 
      Important: Analysis for Office does not do any Load Balancing. The URL set in CMC must work when connecting directly from Analysis for Office to BI Platform.

See Also

2169593 - Incorrect Connection Server details in Analysis Office for MS Excel launcher file from BI Launchpad

Keywords

launcher exited, addin, check logfile, logfile, error, launcher, launching, opening, open, download, view, viewing, workbook, report, reports, analysis, document, documents, launchpad, platform, bi platform, fail, failing, bip, Error checking BOE system, balancer, load balancer , KBA , BI-RA-AO-BIP , AO Precalculation, Scheduling and AO InfoOb... , Problem

Product

SAP Analysis for Microsoft Office all versions