SAP Knowledge Base Article - Public

2324458 - User Item Ratings Not Displayed in Item Search When Rating Results Enabled in "Field Chooser"

Symptom

In the LMS Admin interface, when navigating to Admin > Learning > Item Search > when Items are searched, and the ratings results are enabled in 'field chooser', the ratings column is blank although the User ratings are available for the items:

2016-06-01_11-18-38.png

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Learning Management System

Reproducing the Issue

  1. Navigate to Admin 
  2. Click on Learning 
  3. Go to Item Search and search for an item with the ratings enabled for the particular item.
  4. Notice the Ratings Column will display blank with no apparent ratings associated for the item.

Cause

  • This is an expected LMS behaviour.
  • The 'Rating' column in the Item search does not relate to the user Item ratings, it pertains to an admin rating option that ranges from 0.50 to 5.00 and is used to rate the complexity of Items.
  • The option can be enabled in System Configuration > Record Configuration > under 'Item':

    Enable Ratings.jpg

Keywords

SF, success factors, user, ratings, item, view, LMS, star , KBA , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS , Learning Management System , Problem

Product

SAP SuccessFactors Learning all versions