SAP Knowledge Base Article - Public

2324626 - Workflow not Triggered for History Pages

Symptom

Workflows do not display when performing changes through the History button (clock icon) for Personal Information, Address Information, Job Information or Compensation Information.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

The workflow is triggered and displayed when selecting the Edit button (pencil icon), but when trying to insert a new record or edit an existing one through the History button (clock icon), the change saves successfully without displaying the workflow.

Please note that in this case, if you download the Rule Trace, the workflow will be properly listed, showing that it has been successfully kicked off.

Cause

Workflows do not display when in History mode.

Resolution

This is an expected behavior. History pages does not display workflows.

If you consider this as an important topic for your business requirements, we encourage you to submit an enhancement request, as per KBA 2090228.

Restrict access to the History icon

To restrict the "History" icon so it cannot be accessed, please consider making the following configuration settings in the Granted Users Permission Role for the impacted Effective Dated portlets (example is of the Dependents portlet):

DependentsHistoryIcon.png

Keywords

ECT-53727, Workflow, History, Workflow Trigger, Job Information History, Compensation Information, Personal Information, Address Information, Display, Pop-Up, Rule Trace. , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , Problem

Product

SAP SuccessFactors HXM Suite all versions