Symptom
You have configured a Business Rule to trigger a workflow for a new hire, but the workflow is NOT getting triggered:
- none of the assigned approvers are getting any workflow request
- nor any of the CC persons are receiving email notifications.
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Environment
- SuccessFactors Employee Central
- Workflow Derivation Rules
- New Hire Wizard
Cause
This can be caused by wrong configuration for the rule which triggers the workflow. Still the rule triggering the workflow will be executed, and can be observed with a Rule Trace, but the WF will not be triggered.
Resolution
Ensure the following configuration is followed:
- When triggering workflows from the New Hire Wizard this needs to be separated from the rest of cases where workflows are triggered: a specific rule needs to be created, using as a base object Employee Information or Employee Information Model.
- The SET condition of the rule should use 'Workflow Information' instead of 'wfconfig'.
- The rule to trigger the New Hire workflow is recommended to be put as onSave under the Job Information element.
- RBP is not respected for workflows in the New Hire wizard, so the 'Respect Permissions' flag for each person appearing in the hire workflow should be set to NO
NOTE: For additional information, and an example of this rule, you can refer to the Workflow Implementation Guide. In particular point 13.1 Example Workflow Rules for the New Hire UI
See Also
Keywords
Workflow wfConfig Business Rule New Hire Rehire email cc HrisWorkflowNotificationImpl HrisWorkflowCCNotificationImpl , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC-RUL , DO NOT USE - Business Rules & Event Derivation , Problem