SAP Knowledge Base Article - Public

2327359 - Error message: "Rule(s) SyncPos2Job could not be executed for this record. Please verify that all rules are configured correctly."

Symptom

Customer has created a Business Rule that looks like below and as soon as they turn it ON, the Boomi Interface that updates the JobInfo data in SFSF starts failing with error message- "Rule(s) SyncPos2Job could not be executed for this record. Please verify that all rules are configured correctly."

BusinessRule.jpg

Environment

Successfactors

Cause

Incorrect configuration of the Business Rule.

Company which is a Legal Entity should never be synced with a rule from position to job or job to position synchronization.

Resolution

The reason for this error message is the incorrect configuration and so in order to resolve it, we need to remove the highlighted part from the rule and save it.

BusinessRule.jpg

Once done, the issue will be resolved.

See Also

2232200 - Wrong event reason derivation in position sync

Keywords

Rule(s) SyncPos2Job could not be executed for this record. Please verify that all rules are configured correctly. Issue with Business Rule when updating 'Job Info' via API. , KBA , LOD-SF-INT-API , API & Adhoc API Framework , LOD-SF-INT , Integrations , Problem

Product

SAP SuccessFactors HCM Core 1605 ; SAP SuccessFactors HCM Suite all versions