SAP Knowledge Base Article - Public

2328948 - How To Recalculate Absence When Holiday Calendar Is Updated?

Symptom

  • When Holiday Calendar is updated, how to recalculate existing Time Account balance?
  • What are the next steps after Holiday Calendar is updated?

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP Successfactors Employee Central - Time Off

Reproducing the Issue

  1. Employee applied leave from Monday to Friday i.e so totally 5 days leave.
  2. After that admin added a new entry in Holiday Calendar to make the Wednesday(say) as a Holiday.
  3. Expectation is that the 5 days leave applied should be changed to 4 days and 1 day should be added back to the employee's Time Account balance.

Cause

  • This is an expected behaviour, and currently no automation exists to recalculate an employee's absences, where Holiday Calendar object is updated.
  • However, you can recalculate this data by following a manual process using "Time Management Recalculation Event" (TMRE) object.

Resolution

  1. Make sure recalculation is enabled by following the handbook Enabling Recalculation.
  2. Navigate to Manage Data -> Create New 'Time Management Recalculation Event' as below:
    • TMRE.jpg
  3. Once the object is saved, the absences will be recalculated based on the holiday calendar mentioned. (Refer Viewing Time Management Recalculation Results from the Execution Manager)
  4. For more details, refer handbook Changes Within A Holiday Calendar

Note: It is currently not supported to run the recalculation of absences using TMRE specifically for certain Time Type only.

Time Management Recalculation Event (TMRE) is saved, but absence is not recalculated:

Checks Next Steps
  • If the Time Management Recalculation Event is with status 'completed with errors'.
  • Refer the KBA on how to check the error(s) via execution manager dashboard 2803657 - How To Check The Recalculation Error(s) via Execution Manager Dashboard?)
    • Note: If the TMRE ran without any errors then the object will be automatically deleted, therefore, the TMRE object will no longer be searchable and you may get the error "Object does not exist or you do not have permission". This is expected behaviour).
  • In Admin Tools -> Admin Alerts -> Check for any alerts under 'Recalculate Absences'.
  • Resolve the alerts
  • Check if there are any alerts in Employee's Profile -> Administer Time UI -> 'Time Alerts' tab
  • There shouldn't be any errors in the time alerts tab. If there are any errors, it needs to be fixed and then follow the steps to run the recalculate accruals.
  • Recalculation fails with error 'Your requested time off must include at least one workday. Please change the dates you've entered accordingly', for 1 day leave applied on the new holiday/non-working day.
  1. For the employee with 1 day leave, go to the associated time type and set 'Requesting on Non-Working Days Allowed' as 'Yes'
  2. Create the Time Management Recalculation Event (TMRE) to recalculate the absence.
  3. Once the absence is recalculated, change the 'Requesting on Non-Working Days Allowed' field in the time type back to 'No'
  4. We have an open enhancement for this so that recalculation does not give error if absence exists on a day which becomes a holiday/non-working day later. Please reach out to your CSM/CEE to track the progress of the enhancement "TIM-31284".
  • If flexible Requesting is enabled on the time type, no recalculation will not  even after creation on TMRE.
  • Any recalculations of the time account calculation will not consider changes in the flexible requesting record (Refer Enabling Flexible Absence Requesting)
  • In Manage Data -> Time Type -> If 'Flexible Requesting Allowed' field is set to 'Yes', then the absence will not be recalculated with the TMRE as expected.
  • Is there a Absence Counting Method/Absence Counting Configuration configured for the related Time Account Type?
  1. Navigate to Manage Data > Time Account Type > Check if Absence Counting Method/Absence Counting Configuration is configured.
  2. It may be configured with 'Consider Holidays' as 'No', therefore no absense recalculation will occur to recalculate absence created on a holiday.
  • Check if there are any existing 'Time Management Recalculation Event' (TMRE) for the employees which is in 'To Be Processed' or 'Completed with Error status' 
  • If the related time account is closed, and the "Editable" flag on the employee time is set to 'No', the absence will not get recalculated.
  •  If the absence should be recalculated, then:
    1. Reopen the Time account manually via Manage Data by changing the field 'Closed' to 'No'->  make the related Employee Time as Editable=Yes -> Then trigger a Time Management Recalculation Event again (by following the above steps).
    2. Set the Time Account with Closed as 'Yes'.
    3. NOTE: Making manual changes to Time Account is not recommended and should be done with caution and only if necessary.

For further information on Recalculations, please refer to the Administration Guide "Recalculation in Time Management".

See Also

Changes Within A Holiday Calendar

Recalculation in Time Management

Time Management Recalculation Event

Viewing Time Management Recalculation Results from the Execution Manager

Keywords

Time off, Absence Recalculation, Holiday Calendar, Holiday, recalculation, Time Management Configuration, Time Management Recalculation Event, TMRE, Your requested time off must include at least one workday, Please change the dates you've entered accordingly, TIM-31284, Object does not exist or you do not have permission , KBA , tmre , holiday calendar update , working day , absence , recalculation , non working day , LOD-SF-EC-TIM-REC , Recalculation , LOD-SF-EC-TIM-ABS , Absence error's - Calculations, Deductions, TT&ET , How To

Product

SAP SuccessFactors Employee Central all versions