Symptom
The EC Standard Reports bundle has been uploaded and shows no validation errors, but some reports either show no data or incorrect records (e.g. terminated employees).
Environment
SuccessFactors Advanced Reporting
Reproducing the Issue
Open Time Account Snapshot, check for a recently terminated employee.
Open New Hires, check for any results at all.
Cause
The EC Standard Reports bundle contains templates, not fully ready-made reports. The reason they are classified as such is that customer databases/schemas are varied to the extent that it is impossible to match everything by default.
In particular, many of the reports filter on specific ID codes in fields such as Employment Status. If the default codes are not used by your data, the filters may either include nothing or exclude nothing.
Resolution
Open Report Designer, and check the Owner of each of the reports in the EC Standard Reports folder. If the Owner is "SuccessFactors" the ownership will need to be changed for any non-SF staff to edit them.
Open the suspect report, edit the table component, edit the datasource and edit the Filter section.
If any field is filtered on an ID number as opposed to text (e.g. "Employment Status is not in '2521'"), edit that filter and click Report Values.
The complete list of available codes will appear. If they do not include the selected code, the filter is not having any effect. Select the correct code(s) for your data and save the report.
Keywords
KBA , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, YouCalc, ORD) , Problem