Symptom
While creating a Social Media Channel ex: Facebook, Twitter or YouTube, there is an error message "Social media provider ID is required"
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to Administrator Work Center
-
Go to Service and Social View
-
Select Social Media Channels and click on New
-
Complete the steps until 3. Connect With Channel
-
Now on Step 4, fill the details and click on Get Account Details
Cause
Before creation of the social media, a Mashup Service ID must be setup in the system
Resolution
Please follow the below steps to set up the a Mashup Service ID
-
Go to Administrator Work Center
-
Go to Business Flexibility View
-
Select Mashup Web Services and click on New
-
Now choose the New and RSS/Atom Service
-
Provide the service name, description and Facebook/Twitter page URL
-
Choose the Save button
-
Once the Service provider is created, you will be able to establish the connection between Cloud for Customer and the Social Media.
Keywords
facebook, twitter, Social Media, get account details , KBA , LOD-CRM-SC-SM , Social Media , Problem
Product
SAP Cloud for Customer add-ins all versions