Symptom
- Unable to proceed with the application using mobile devices
- Message "A larger screen is required, so please open the email with a full-scale device".
Environment
- SAP SuccessFactors Recruiting Marketing
- SAP SuccessFactors Recruiting Management
- SAP SuccessFactors Mobile
Reproducing the Issue
- Navigate to the RMK website using the mobile device.
- Search for any active job and try to apply.
- Once the email has been submitted, message will be displayed "Thank you. You should receive an email containing a link to this job along with details on how to apply. A larger screen is required, so please open the email with a full-scale device".
Cause
- Use Business Card Apply for Mobile (Standard & Responsive) is disabled
- Mobile Version (Legacy) is enabled
Resolution
For a seemless apply workflow froma mobile device the following settings must be set in the CSB site settings:
- Legacy Mobile – set to OFF
<mobileversion>false</mobileversion> - On-Page Business Card - set to ON
<useonpagebusinesscard>true</useonpagebusinesscard> -
Use Business Card Apply for Mobile (Standard & Responsive) - set to ON
<usemobiletc>true</usemobiletc>
These settings can now be checked and changed in Career Site Builder.
- Go to CSB > Tools > Import & Export > Export tab;
- Export the Site Settings twice (important note: keep two copies of this file - one unmodified as a backup in case anything goes wrong so you can restore the original configuration, and one that you will modify);
- Open the file you will be modifying with a text or XML editor (e.g. Notepad++, Oxygen, etc...);
- Modify the settings in the XML file as outlined above
- Save the file;
- Go to CSB > Tools > Import & Export > Import tab;
- Import the Site Settings using the modified file;
- Reload the page
See Also
Keywords
Larger screen is required, link to apply in mobile, RMK, Recruiting Marketing, Unable to apply, External Site, CAS, Mobile Device , KBA , LOD-SF-RMK-CC , Command Center , Problem
Product
SAP SuccessFactors Recruiting all versions