Symptom
- After doing a full purge on job history, the user is trying to import manager’s data using incremental load.
- Both the imports are successful, however once we open the employment details for the employee, user information cannot be found.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HCM Suite
- SAP SuccessFactors Employee Central
Reproducing the Issue
- User able to view information after full purge on JOB INFORMATION without managers data being imported.
- Press Ok - job information details are empty
- Go to history > application error pops up:
errorId=328b96e3-696b-472b-a1c8-4f5c8fbb9e9f, timestamp=2015-11-24T21:44:52.855+0100, server=#######, versionInfo=Release%3A%20b1508.879783%0A%20%20%20%20Server%3A%2010PC12BCF24%0A%20%20%20%20Timestamp%3A%202015-11-24T21%3A44%3A51.337%2B0100
Cause
- Customer has not imported the personal information for the employees, thud this was giving an error while uploading the manager's data.
- Also, there was no HRIS sync scheduled for the instance, resulting in the data not being synced to EP.
Resolution
- Upload the employment information(full purge) data for the employee.
- Upload Personal Information data for the employees
- Run a full HRIS SYNC job to sync the data to EP
- Import managers data using incremental upload for job history.
Keywords
f , KBA , LOD-SF-EC , Employee Central , Problem
Product
SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions
Attachments
HRIS SYnc issue.docx |