Symptom
Benefit enrolment amount is not set to null in workflow approval page
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Environment
Successfactors - Employee Central
Reproducing the Issue
The customer has a benefit ‘Company Car Lease Plan Allowance’.
On Enrolling for it, the employee should enter either ‘Enrollment Amount’ or ‘Benefit Company Car Enrolment’ section and not both together.
Suppose, I enter only ‘Benefit Company Car Enrolment’ section, leaving the field ‘Enrollment Amount’ blank and Save.
The workflow gets triggered, and the value of ‘Enrollment Amount’ is displayed as ’40,000’ even though it was not entered during enrollment.
That is, if no value is entered the system defaults the value of field ‘Enrollment Amount’ to the value of ‘Benefit Entitlement amount’
Cause
Enrolment amount can never be null.
It needs to be set with a value, at least zero.
Resolution
The below sample rule can be configured as a workaround which sets the Enrolment Amount to Zero if any of the Benefit Company Car Enrolment details are entered.
Assign the rule to validateRule section of ‘Benefit Enrolment’ object definition.
The result will be as below. The enrolment amount is set to zero.
Keywords
Benefit Enrolment Amount , KBA , LOD-SF-EC-GBF , Global Benefits , Problem