Symptom
The skillsoft connector appears to run for 30 minutes and then fails, error logs show the following:
WARN Max Polling threshold interval of 1800000 ms exceeded, failure in recieving metadata from Skillsoft!
Cause
The default connection time has been exceeded and the connection to skillsoft was cancelled by SF. By default the polling threshold timeout is set to 1800000 ms or 30 minutes.
There are two configuratiuon settings that can be added to the connectors config file regarding skillsoft timeouts.
# OLSA Connector Data polling threshold timeout - in milliseconds
skillsoft.connector.polling.threshold.timeout=1800000
# OLSA Connector Web service client timeout - in milliseconds
skillsoft.connector.service.connection.timeout=60000
The polling threshold will be the total time the connection from SF to skillsoft is available whereas the service connection is the time we retry to see if the file is ready from successfactors.
Resolution
Try increasing the following timeout in 30 minute increments until the connector runs successful.
*Note: if connector still times out after setting the timeout to 2.5 hrs then please contact Professional Services for further assistance.
# OLSA Connector Data polling threshold timeout - in milliseconds
skillsoft.connector.polling.threshold.timeout=1800000
Keywords
SF SuccessFactors success factors LMS skillsoft olsa connector , KBA , LOD-SF-LMS , Learning Management System , Problem