SAP Knowledge Base Article - Public

2336875 - Accept Match Button Missing in Add New Employee Wizard - Employee Central

Symptom

The 'Accept Match' button is missing in Add New Employee wizard.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

  • SAP SuccessFactors Employee Central
  • Hire/Rehire Wizard

Reproducing the Issue

  1. Add a new user via the Add New Employee wizard.
  2. The Duplicate Check pop-up appears after clicking 'Continue' on the Identity section.
  3. The Accept Match button is missing.

AcceptMatchMissing.jpg

Cause

This is an expected behavior.

Resolution

  • The 'Accept Match' button will be not be available if the user is still active in the system; only Terminated employees can be used for the 'Accept Match' button.
  • The 'Accept Match' button will also be missing if the user did not have a valid termination record in jobInfo. The inactive user should be terminated correctly for the 'Accept Match' button to appear during rehiring process.
  • If the 'Accept Match' button is missing even for correctly terminated users, then the following permissions under category "Manage Hires" are not granted to the user and need to be granted to use the feature.

new hire match screen1.png

Keywords

PP3, People Profile 3, Accept Match, Add New Employee, Accept match missing, accept match blank, accept match grayed out , KBA , LOD-SF-EC-HIR , Hire & Rehire Wizards , Problem

Product

SAP SuccessFactors Employee Central all versions