Symptom
You are not able to update the address of a contact using both Mass Data Maintenance & Migration of Customers activity.
1) When you try to update the Address of a Contact using the activity Migration of Customer, you get the below error message:
Error: Update not possible; specified data for CUSTOMER-CONTACT_PERSON with key UUID-CONTENT = `XYZ` does not exist
Or
2) When you try to update the Address of a Contact using Mass Data Maintenance, no changes happen in the Address tab of Customers after successful execution.
Reproducing the Issue
1) Go to Mass Data Maintenance workcenter
2) Select Import Customer link.
Or
1.Go to Business Configuration workcenter
2.Select Implementation Projects view.
3.Search and Open the migration activity of Customers
4.Execute Migration for the respective Migration File
Note: The mode of migration is Modify Already Existing Records
Cause
This is expected system behavior. Modify Already Existing Records or Enhance Already Existing Records is not supported to update Address of a Contacts.
Resolution
You can manually update/add the Address of a Contact from user interface following the below mentioned steps:
1. Go to Customers workcenter.
2. Select Contacts view
3. Select the tab Address
4. Select the required information address and update.
5. Select the Save button to save the changes
Keywords
KBA , LOD-CRM-WKF , Workflow , How To