Symptom
You have created few extension fields in a Business Object Header and added it to ODATA Service. When opening the business record in SAP JAM, the extension field is not visible and cannot be added.
Example: Extension field UFP Sales Area in business object Opportunities is not visible on SAP JAM.
Reproducing the Issue
1.Select Opportunity workcenter
2.Select the button Adapt to Enter Adaptation Mode
3.Select Edit master layout option.
4.Search the required extension field e.g. UFP Sales Area Austria(A)
5.Select Settings and then Field Definition
6.Select ODATA
7.The checkbox C4C.svc is adapted should be checked.
Further follow the below mentioned steps to check the extension fields in the SAP JAM:
8.Go to the workcenter Feed
9.Select SAP JAM
10.Select Administrator
11.Select Integration
12.Select External Application
13.Select Action
14.Select Manage Types
15.Select Opportunity and Edit
16.Go to the tab Business Records
17.Select and open any Opportunity
Cause
JAM admin user needs to update the Record type after adding extension field to C4C.svc service,
Resolution
Follow the below mentioned steps to update the extension fields:
1. Go to SAP JAM
2. Select Manage Record Types
3. Select Edit the required BO (i.e. Opportunities)
4. Select Import External Resources,
5. When import is successful,
6. Select the Update button.
NOTE: Even after following the above mentioned steps if the extension fields have not got added then follow the below steps:
1. First remove all the extension fields from c4c.svc service and re-add them.
2. While removing or re-adding, please wait untill you get a message as Field added successfully.
3. After that Go to JAM and reimport Annotations and it should be available.
4. Before importing annotations, make sure that fields are added to c4c.svc service.
Keywords
KBA , SRD-CC-FED , Feeds , How To