SAP Knowledge Base Article - Public

2339101 - Admins and Users Proxied into a User Account Cannot Launch Content

Symptom

  • The "Start Course" button is missing when BizX and/or LMS users (or administrators) proxy into a user account.
  • In the BizX Platform, the error message "The requested operation is not available" is displayed.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Learning Management System

Reproducing the Issue

  1. Logon to the instance as an Admin
  2. Select a user
  3. Click Launch Proxy

    launch_proxy.PNG

  4. Review the Learning Plan of the user and try launching the online courses available.
  5. No button is displayed to launch the online content.

Cause

This is an expected behavior of the system.

Resolution

  • Administrators and users are unable to launch online content on a Learning Plan when they proxy in as a user.
  • Allowing them to complete learning could compromise the integrity of the data regarding the completion of online courses.

Example: if an admin proxies as a user and completes an item, there would be no way to track who has actually taken the course.

Keywords

SF Success Factors LMS Learning continue, resume, proxy, survey, launch course item compliance, The requested operation is not available, course , KBA , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-CNT , Content , Problem

Product

SAP SuccessFactors Learning all versions