SAP Knowledge Base Article - Public

2339265 - From address cannot be selected when sending an ad-hoc notification

Symptom

Admin is trying to send an ad-hoc notification to any user, however "from address" field is not prepopulated automatically, neither can be selected.Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Navigate to any user record
  2. Click 'Send Notification' under Actions menu
  1. In next step you will see that from address is not prepopulated with any address and you cannot type in any address

2.PNG

Cause

The admin Email address has to be populated on admin record if the option "admin" is selected for "send notification from" settings.

Resolution

  1. Navigate to System Admin > Configuration > Global Variables > mail tab
  2. Go to the "send notification from" field

There are two possible options you can select from.

  • If you select "Admin option" (this caused the issue), then the from address will be automatically prepopulated with the email address of the admin who is currently logged in. However, if the admin does not have an email address set up, please navigate to this Admin account:
    • System Admin > Admin Management > Search for the admin > Add email address in summary
  • If you select the last option "Select from list" - then you can type each email addresses deliminated by comma and they will be displayed in a drop down menu when sending an ad-hoc notification and selecting from address.

Keywords

from address cannot be typed in, ad hoc notification, send notification from, sender , KBA , LOD-SF-LMS-NOT , Notifications , LOD-SF-LMS , Learning Management System , Problem

Product

SAP SuccessFactors Learning all versions