Symptom
How to update application status using SFAPI?
Error Internal error occurred! when updating application status using SFAPI
e.g.:
<?xml version="1.0" encoding="UTF-8"?>
<S:Envelope xmlns:S="http://schemas.xmlsoap.org/soap/envelope/">
<S:Header/>
<S:Body>
<ns2:Fault xmlns:ns2="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns3="http://www.w3.org/2003/05/soap-envelope">
<faultcode>ns2:Server</faultcode>
<faultstring>Internal Error!</faultstring>
<detail>
<ns2:SFWebServiceFault xmlns="urn:sfobject.sfapi.successfactors.com" xmlns:ns2="urn:fault.sfapi.successfactors.com">
<ns2:errorCode>INTERNAL_ERROR</ns2:errorCode>
<ns2:errorMessage>Internal error occurred!</ns2:errorMessage>
</ns2:SFWebServiceFault>
</detail>
</ns2:Fault>
</S:Body>
</S:Envelope>
Environment
- Recruiting Management
- SFAPI
Reproducing the Issue
Update statusId in the JobApplication entity using SFAPI
Cause
If the data in the statusId field will be managed via API, in the statusId field definition within the Application Template XML set up and associate a picklist with values exactly matching the applicant status workflow set up in Admin Centre > Edit Applicant Status Configuration.
Resolution
Modify the picklist linked with the field definition "statusId" in the Application XML so that it contains exactly the same values as specified in Admin Centre > Edit Applicant status configuration for the status set linked with the application template in question.
Keywords
KBA , LOD-SF-RCM-API , Webservices & APIs , LOD-SF-INT-API , API & Adhoc API Framework , Problem