SAP Knowledge Base Article - Public

2342574 - Candidate is unable to Sign Out - Recruiting

Symptom

Clicking on the Sign Out link in the RCM external website doesn't allow the candidate to log out or to be redirected to RMK (Recruiting Marketing). This is regardless of the browser used.

Environment

  • SAP SuccessFactors Recruiting Management (RCM)
  • SAP SuccessFactors Recruiting Marketing (RMK)

Reproducing the Issue

Scenario 1

  1. Access RMK site
  2. Apply for a Job
  3. Create a new Profile or log in
  4. Try to log out by clicking in Sign Out.

Scenario 2

  1. Access your company's external career site, https://careerX.successfactors.com/careers?company=XYZ (Here "X" to be replaced with the datacenter like 4/8/10 etc)
  2. Create a new user account or logon with an existing username-password.
  3. Try logging out using the ‘Sign Out’ button in the top right corner.

Result

Nothing happens or this is being redirected to the incorrect page.

Cause

This is due to an incorrect configuration in Provisioning > Configure Recruiting Marketing Datacenter URLs.

Resolution

The configuration responsible for this comes from the Successfactors backend system known as Provisioning.

Follow the steps below to update the configuration:

  1. Go to Provisioning > Configure Recruiting Marketing Datacenter URLs > RMK Job Search URL
  2. Please ensure that the url doesn't have any additional typos or incorrect characters
  3. Save your changes and reload the career page. The issue would be resolved. 

The above steps should be done by a Implementation Partner or Professional Services consultant.

Keywords

Sign Out, Log Out, SignOut, RCM, RMK   , KBA , LOD-SF-RCM , Recruiting Management , Problem

Product

SAP SuccessFactors Recruiting all versions