Symptom
When trying to create Payment Information data for an employee, you encounter the following error -:
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
But Job Information has correct data -:
Environment
- SAP SuccessFactors Employee Central
- Payment Information
Reproducing the Issue
When trying to create Payment Information data for an employee, even though Job Info does have Country value set, you encounter the following error -:
"Sorry, it is not possible to maintain payment information if there is no job information or no country in job information"
Cause
- In b1508, a new column (internal flag) was added to Job Info, Comp Info & Recurring Pay Component tables to track "Effective Last Change". The job did not run for all customers at point of release in b1508 indicating that Historical records are not updated for this customer. To manually run the flag update (which will have no impact on customer data) we can configure the job in provisioning and run it and then try to create Payment Information again.
- The job country field is set as not visible in Payment Information Object.
- The job country and Worker ID are not enabled in Payment Information UI in Manage Configuration UI.
Resolution
- Product Support can schedule the required job to add the flag to existing records in the database. The job will have no impact on actual data, just to add a flag value to the new internal column (not visible to customers)
How to setup the job in Provisioning:
In Provisioning => Manage Jobs => Create new job => select below appropriate job types and run it once for the instance.
- Job Info:Initialize effective latest change flag for job information
- CompInfo & PayCompRecurring: Initialize effective latest change flag for comp info
It is recommended to both jobs in the above order.
If issue still persist after this, you can refer to below resolution.
-
Set the visibility job country field in Payment Information Object to "read-only"
To do this please follow below steps:
1. Navigate to Admin Center > Company Settings
2. Click on Configure Object Definition
3. Search for Object Definition > Payment Information
4. Click on Take action > Make Correction
5. Click on the details on the right side of the field "jobCountry".
6. Change the Visibility to "Read Only" > Save.
Next thing, make sure that the job country and Worker ID fields are enabled in Payment Information UI in Manage Configuration UI.
1. Go to Admin Center > Manage Configuration UI
2. Search for Payment Information.
3. Check if Worker ID and Job Country are enabled.
4. If Job Country and Worker ID is not enabled then click on Create New > enter the ID for UI > Select Base Object: Payment Information > Save.
5. Once all set, you can now reproduce the issue again.
See Also
2443445 - Error in Payment Information: "Sorry, it is not possible to maintain payment information if there is no job information or no country in job information."
Keywords
ECT-54483, Payment Information, job information, country, Sorry, it is not possible to maintain payment information if there is no job information or no country in job information, Payment Info Error, paymentinfo, error in payment, jobCountry, Worker id , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , LOD-SF-EC , Employee Central , Problem